Probleme beim Ubuntu-Upgrade von Oneiric Ocelot auf Precise Pangolin

Eigentlich hatte ich das ja immer erwartet und bin bei den letzten zwei Upgrades Lucid auf Natty und dann auf Oneiric positiv überrascht worden. Nach den umfangreichen Upgrades ist das Ubuntu immer ohne Probleme in frischem Glanz gestartet und arbeitete Problemfrei, bis auf Kleinigkeiten.

Diesmal brach es beim Precise-Upgrade allerdings schon direkt beim Upgrade ab (blieb aber jederzeit benutzbar), mit folgender Fehlermeldung ..

E:Couldn’t configure pre-depend libtinfo5 for libncurses5, probably a dependency cycle.

Das Problem schien schon bekannt zu sein, da es diverse Diskussionsthread auf dem Bugtracker bei launchpad.net gab. Allerdings für mich zielführend war dann die Lösung die ein Blogger presentierte. Es lag auch nahe die monierten 3 Pakete manuell zu downloaden und zu installieren. Also hier im Detail .. man muss die Ubuntu 12.04-Versionen der Pakete libtinfo5, libncurses5, and libncursesw5 (in genau der genannten Reihenfolge) mittels dpkg -i <Paketdateiname.deb> installieren.

Und schon läuft der Upgrade-Prozess erneut angestossen via do-release-upgrade wieder komplett durch. Und sofern man vermeidet ein apt-get clean zwischeendurch zu machen, dann braucht man auch nicht nochmals 1000sende Pakete erneut zu downloaden.


Links

https://bugs.launchpad.net/ubuntu/+source/apt/+bug/924079

http://aaron-kelley.net/blog/2012/04/upgrade-from-ubuntu-11-10-oneiric-to-ubuntu-12-04-lts-precise-fails-with-error-couldnt-configure-pre-depend-libtinfo5-for-libncurses5-probably-a-dependency-cycle/

Send to Kindle
Kommentar schreiben

0 Kommentare.

Kommentar schreiben


Hinweis - Du kannst dies benutzenHTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>