Archiv nach Schlagworten: Ubuntu

Einstellungen in der /etc/security/limits.conf werden unter Debian/Ubuntu ignoriert ?

Symptome

Änderungen an globalen Beschränkungen für Prozesse via limits.conf werden nicht angenommen oder ausgeführt.

Abhilfe

Die Lösung besteht darin zu prüfen, ob das entsprechende PAM-Modul bei einem Start einer neuen User-Session auf aufgerufen wird. Einen solchen eventuell fehlenden Eintrag kann man einfach mittels folgender Kommandozeile hinzufügen.

  
echo -e "\n session required pam_limits.so \n" > /etc/pam.d/common-session.conf
  

Die Änderungen sind direkt für alle neuen User-Sessions aktiv. Das heisst man müsste sich ggf. jeweils nur noch mal neu einloggen und/oder entsprechende Prozesse neu starten.

Links

http://doookstechstuff.blogspot.de/2010/08/how-to-stop-debian-ignoring.html

Grub2-Bootloader mittels Linux-Boot-CD reparieren

Wer häufiger an Linux-Systemen „rumbastelt“ stand bestimmt schon einmal vor diesem Problem. Insbesondere wenn man Dateisystem verschiebt, cloned oder anderweitig verändert und der Grub-Bootloader danach ein Linuxsystem nicht mehr ordnungsgemäss booten will. Wenn man in so einem Fall eine Linux-Boot-CD wie die SystemRescueCD oder die GRML zur Hand hat, dann ist das Problem schnell beseitigt.

Weiterlesen »

(Debian/Ubuntu) Bandbreite von apt limitieren

Linux-Anwender die in Zeiten allgegenwärtiger Breitbandzugänge, dennnoch gerne die von apt, sowie aller darauf basierenden Tools, genutzte Bandbreite (Downloads von Paketen, Update von Paketlisten) beschränken möchten dürfte es genügend geben. So hat es mich gerade auch gestört, das man bei einem Update bzw. Installation eines großen Software-Paketes (wie etwa der Linux-Kernel) jedesmal zum Warten verdammt ist, da etwa für das Browsen im Internet nicht mehr genügend Bandbreite übrig ist.

Weiterlesen »

Entwicklung der Linux-Distributionen über die letzten 20 Jahre


Links

https://plus.google.com/u/0/104940068838189453727/posts/NuXCfQeMrBS

hpacucli – HP Smart Array Tool funktioniert nicht mit Linux-Kerneln >3.x

Eine böse Überraschung ergab sich als ich nach einiger Zeit nach einem Software-Upgrade mit den Smart-Array-Tools von HP/Compaq den Zustand eines Plattenarrays eines Servers remote checken wollte. Das Tool hpacucli brach schlicht mit der Meldung „Error: No controllers detected“ ab.

#> hpacucli ctrl all show
Error: No controllers detected

In diesen Zustand wollte ich definitiv nicht abwarten bis irgnendwann nach ungewisser Zeit ein Update das Problem behebt. Also selbst ist der Admin und recherchiert zum Zwecke der Selbsthilfe, ob es da nicht einen Workaround gibt.

Weiterlesen »

Seite 1 von 6123456