Archiv nach Schlagworten: fcdsl.ko

AVM Fritz CAPI Treiber unter Debian Lenny compilieren

Flattr this!

Alle Jahre wieder kommt man in die Verlegenheit schlecht unterstützte Hardware unter Linux zum laufen zu bewegen. Ein solcher Fall sind die verschiedenen ISDN-Karten und Terminal Adapter der Fritz Serie von AVM. AVM hat irgendwann 2007 die Linux-Unterstützung aufgegeben und keine Treiber-Updates für neue Kernel released, leider sind die Treiber Closed-Source bzw. AVM wollte wohl auch nicht die weitere Entwicklung in Community Hände geben.

Im Netz findet man dazu jede Menge hilfereicher Tips und Tricks sowie Patches dazu. Doch mit jeder neuen Kernel-Gerneration kommen auch wieder neue Probleme hinzu und die alten Tricks helfen nicht mehr weiter. Und wenn man aus bestimmten Gründen nicht gleich einen kompletten Kernel samt der Fritz-Module compilieren will, dann wird es noch komplizierter. Das aktuellste was ich an gepatchen Sourcen gefunden habe, war ein Archiv für Kernel 2.6.24 und die Kanotix Distribution.

Weiterlesen »

Seite 1 von 11
Wir benutzen Cookies um die Nutzerfreundlichkeit der Webseite zu verbessen. Durch Deinen Besuch stimmst Du dem zu.
n/a